This page provides a real-time overview of Intersolve system status, details on upcoming scheduled maintenance, and a record of past incidents.

External product - Service disruption

Incident Report for Intersolve

Resolved

This incident has been resolved.
Posted Sep 02, 2026 - 14:49 CEST

Monitoring

Issue with the Tillo Euro products seem to be solved.
We are monitoring the situation
Posted Sep 02, 2026 - 14:38 CEST

Identified

There is currently an issue with all Tillo Euro products.
This may cause transaction issues when processing these products.
We are in contact with Tillo and are investigating the issue
Posted Sep 02, 2026 - 14:26 CEST
This incident affected: Card service providers.